“Kali初始化”的版本间的差异

来自linux中国网wiki
跳到导航 跳到搜索
→‎IM
第453行: 第453行:
 
[http://community.wps.cn/wiki/No_necessary_symbol_fonts wps字体]
 
[http://community.wps.cn/wiki/No_necessary_symbol_fonts wps字体]
  
 +
=== CAD ===
 +
==== freecad====
 +
sudo add-apt-repository ppa:freecad-maintainers/freecad-stable
 +
sudo apt update
 +
  sudo apt install freecad
 +
 +
https://wiki.freecadweb.org/Install_on_Unix/zh-cn
 +
https://launchpad.net/~freecad-maintainers/+archive/ubuntu/freecad-stable
 +
 +
https://github.com/FreeCAD/FreeCAD/releases/tag/0.18.4
 
=== email ===
 
=== email ===
 
 
====[[thunderbird]]====
 
====[[thunderbird]]====
 
  
 
== emacs26 in Ubuntu 18.04==
 
== emacs26 in Ubuntu 18.04==

2020年6月30日 (二) 08:00的版本

目录

2020

將硬盘模式由RAID 可以进入原来的win 改为ACHI 就进入其它第三方os

Ubuntu ®/WIN10双系统安装教程

https://www.dell.com/support/article/zh-cn/sln301754/%E5%A6%82%E4%BD%95%E5%9C%A8-dell-pc-%E4%B8%8A%E5%AE%89%E8%A3%85-ubuntu-%E5%92%8C-windows-8-%E6%88%9610%E4%BD%9C%E4%B8%BA%E5%8F%8C%E5%BC%95%E5%AF%BC?lang=zh


第一步在 win中分区中压缩出给unix的空间 Win10系统相关 现在要什么改bios为AHI 原来的是ran0 on 是不是得重启安装win 问一下售后 更改xps13的硬盘模式

Dell xps13 的硬盘模式有三种:RAID(默认)模式; ACHI模式;以及以上两种的混合模式。RAID模式下我们是无法安装ubuntu的,于是在开机dell图标的时候猛按F2进入BIOS选项,將硬盘模式由RAID改为ACHI, 在更改时系统会提醒若更改可能会导致无法逆转的问题,其实没关系,确认更改。注意,更改了硬盘模式之后是无法在进入win10的,所以这时候可以在USB接口插好我们准备好的ubuntu安装盘了,在系统重启进入dell图标界面时,猛按F12进入boot界面选用U盘启动,进入ubuntu安装界面然后正常安装就好。关于安装ubuntu时的分区,我参考了网上的教程,采用以下分区:


分区完成后,不要急着下一步,这里还要选择 安装启动引导器的设备

选择boot所在的分区 /dev/sda ?


xps 13 7390 安装双系统


linuxqq 在debian 10上用 sh 安装是成功的 weixin用一下 docker那个 就不用虚拟机了



安装参考这个喽 一开始不要安装太多桌面 就先xfce作备用 然后再上awesome

默认安装,想要更多工具

 sudo apt-get -y install kali-linux-large

安装过程 有grub2修复呢


kali 2020.1安装(图文超详细版)


kali linux 2020.1安装注意事项

start

此文适合于 debian10初始化 20190730


Debian_stretch 也就是 debian 9 这也是kali2018

最常用软件

synapse (上次回车运行不了软件是 自己小小心 把运行配置设置为f2)  ;geany ;  catfish 文件查看;

  zim ; ;

国内iso下载地址

kali 的国内官方镜像为东软信息学院 所以下载地址有两个

http://mirrors.neusoft.edu.cn/kali-images/

公司这个下载比较快

http://mirrors.163.com/kali-images/

https://mirrors.ustc.edu.cn/kali-images

https://mirrors.tuna.tsinghua.edu.cn/kali-images/

[email protected]:~/iso$ sha256sum kali-linux-2017.2-amd64.iso 
4556775bfb981ae64a3cb19aa0b73e8dcac6e4ba524f31c4bc14c9137b99725d  kali-linux-2017.2-amd64.iso

time sudo dd if=xxxxx.iso of=/dev/sdc && sync  # real	23m33.039s
或者用什么 img32  linux 下还可以用 etcher U盘镜像复制工具

Create bootable USB drives

https://rufus.ie/

sudoapt-getinstallusb-creator-gtk


https://www.balena.io/etcher/


win下的hash tools hash my files divhasher

creating-and-using-a-live-installation-image

http://www.ubuntukylin.com/public/pdf/1910.pdf

debian

附带专有固件的非官方镜像也已更新,如果您发现Debian与某个硬件不兼容,这些非自由版本很有用。

sudo apt-get install -y dnsutils#dig 

debian elite 无线驱动 iwlwifi-7260-17.ucode

debian 10 elite 无线驱动  iwlwifi-7260-17.ucode

#wifi 添加源
deb http://mirrors.163.com/debian/ buster main contrib non-free

apt  install firmware-iwlwifi wireless-tools

常用包安装

sudo apt install net-tools

pre

Parrot安装

 
如果发现不是中文界面 settings -->Region &language  选择中国  再次登录就是中文了

允许root登录 
#PermitRootLogin prohibit-password
PermitRootLogin yes  #/etc/init.d/ssh restart 

新用户  debain 系统建议用adduser
adduser evan #这个是交互的 

useradd  evan -m  -s /bin/bash  -g evan

#is debian 
apt install sudo -y 
 
echo 'evan ALL=(ALL) NOPASSWD:NOPASSWD:ALL' >/etc/sudoers.d/evan

回收站 .local/share/Trash/files/

useradd与adduser的区别

分区

kalilatop  /  27G  建议大一些好   我的现在是20G 昨晚更新时就空间不太够 清理了今天一个上午 ,昨天还搞到半夜
cd /var/cache/apt/archives && rm -rf *.deb

在公司电脑上 居然要安装成 /home不独立出来,不然会安装不成功 搞笑 第一天不行 第二天又可以 了 哈哈 #应该是硬盘没删除成功 我发现还有 原来的数据呀

输入法

fcitx

 sudo apt-get install fcitx fcitx-table-wbpy ttf-wqy-microhei ttf-wqy-zenhei


#官方提示
设置 用户设置 /home/evan/.xinputrc 为 fcitx。
手动设置选择: fcitx
小企鹅输入法(Fcitx)
 * 必需组件:fcitx
 * 输入特定语言所需的组件:
   * 简体中文拼音:fcitx-sunpinyin 或 fcitx-googlepinyin 或 fcitx-pinyin
   * 简体中文五笔:fcitx-table-wubi 或 fcitx-table-wbpy
   * 繁体中文:fcitx-table-cangjie
   * 通用的输入法码表: fcitx-table* 套件
 * 应用程序支持:
   * GNOME/GTK+:fcitx-frontend-gtk2 和 fcitx-frontend-gtk3
                  (强烈建议同时安装)
   * KDE/Qt4:fcitx-frontend-qt4

用户设置 已被 im-config 修改。

请重新启动 X 会话管理器以激活新的 用户设置。
如果使用旧配置的守护进程被 X 会话管理器重启,您可能需要使用 kill(1) 手工将其杀死。
请参考 im-config(8) 和 /usr/share/doc/im-config/README.Debian.gz


# skin 

下载皮肤并解压缩到下面任一目录,如果没有可以新建目录:

/usr/share/fcitx/skin   ##全局设置
~/.config/fcitx/skin    #特定用户设置


debian  kali

ls /usr/share/fcitx/skin/
classic  dark  default  google  sogou


freebsd 

 .config/fcitx/skin/
Alpha		google		material	sogou		startos

皮肤下载 sogou 不错 http://mirrors.163.com/deepin/pool/main/f/fcitx-skins/

arch fcitx

Linux下Qt4与qt5的程序使用输入法(ibus与fcitx)不冲突


解决 Ubuntu 16.04 下 Telegram Fcitx 不能加载的问题

ibus

#sudo apt-get install ibus-gtk  ibus-table-wubi    #不好用 暂时不用       ibus-setup

openssh

apt-get install openssh-client openssh-server
这个要先安装 不然自启动会不成功

如何激活服务并在启动时启用或禁用服务(即系统启动时自动启动服务)
# systemctl is-active ssh.service
systemctl enable ssh.service
# systemctl disable ssh.service

debian系统下安装ssh服务超级详细

更新系统

#配置源 又可以改为国内源了 记得在去年是不可以的 20180222 2020
#eg
sed -i "[email protected]@[email protected]" sources.list
sed -i "[email protected]://.*[email protected]://[email protected]" /etc/apt/sources.list
sed -i "[email protected]://.*[email protected]://[email protected]" /etc/apt/sources.list 




deb https://mirrors.ustc.edu.cn/kali kali-rolling main non-free contrib
deb-src https://mirrors.ustc.edu.cn/kali kali-rolling main non-free contrib

#aliyun是最快的 配置上他的dns 2020 但是官方源才是软件最新的哦 
deb http://mirrors.aliyun.com/kali kali-rolling main non-free contrib
#deb-src http://mirrors.aliyun.com/kali kali-rolling main non-free contrib
#deb http://mirrors.aliyun.com/kali-security kali-rolling/updates main contrib non-free
#deb-src http://mirrors.aliyun.com/kali-security kali-rolling/updates main contrib non-free
#
#office 
#deb https://http.kali.org/kali kali-rolling main non-free contrib
#deb http://http.kali.org/kali kali-rolling main non-free contrib

kali 的国内官方镜像为东软信息学院
所以只要dns是国内 应该 会自动去东软信息学院mirrors的

apt-get update

#一般只更新自己要的软件就好了,不要全系统更新 容易挂 再说 很多软件更新也没用嘛 
apt install xxxx # apt list --upgradable |less 查看软件
apt upgrade
apt-get dist-upgrade #跨版本更新 ; 发布版升级

apt update && apt full-upgrade #升级2018的官方 命令
 

更新系统故障

 [email protected]:~/github/python/tutorial$ sudo apt update 
获取:1 http://mirrors.aliyun.com/kali kali-rolling InRelease [30.5 kB]
 错误:1 http://mirrors.aliyun.com/kali kali-rolling InRelease  
  下列签名无效: EXPKEYSIG ED444FF07D8D0BF6 Kali Linux Repository <[email protected]>

正在读取软件包列表... 完成           
W: GPG 错误:http://mirrors.aliyun.com/kali kali-rolling InRelease: 下列签名无效: EXPKEYSIG ED444FF07D8D0BF6 Kali Linux Repository <[email protected]>
E: 仓库 “http://mirrors.aliyun.com/kali kali-rolling InRelease” 没有数字签名。
N: 无法安全地用该源进行更新,所以默认禁用该源。
#使用root 运行此命令
[email protected]:~# wget -q -O - https://archive.kali.org/archive-key.asc | apt-key add
OK 

Kali Linux 2018.1 Release

添加 home分区

cp  -a .bash_history              .chromium-bsu              .gnupg/                    .pki/                      .ssh/                      .xinputrc  .bak

把所以 . 隐藏的文件 先 ls . 然后得出的 放到 .bak目录 最后再放出来  


算了 直接搞个/data分区了 
  mkfs.ext4  /dev/nvme0n1p9


blkid /dev/nvme0n1p9

cat /etc/fstab 
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/nvme0n1p8 during installation
UUID=8239d727-9b16-4e03-bf2d-d05766db6a2e /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/nvme0n1p1 during installation
UUID=0848-0943  /boot/efi       vfat    umask=0077      0       1
# swap was on /dev/nvme0n1p7 during installation
UUID=753c3bee-a5b7-4de4-b0bf-1d971622d47a none            swap    sw              0       0
# /home  was on /dev/nvme0n1p9 during installation
UUID=a90d5fe4-482b-458a-bc8b-fd733fd963d2  /data              ext4    errors=remount-ro 0       1


添加新硬盘

UUID=d94216fb-5712-dc44-ad1e-98534d6e4bae /mydata           ext4    defaults        0       2
#后来成为home 要记得改为 /home
mkdir /home/evan/data
uuid 查看
blkid
blkid /dev/sdb1 

#mydata 2T hdd 2018年 09月 25日 星期二 10:22:06 CST
#/dev/sdb1   /home/evan/data    ext4    defaults        0       0
UUID=7664f2b3-ee40-4861-aed4-c6fd223126ac /home/evan/data           ext4    defaults        0       2

fstab 改为 /dev/sdb1 就好了 而不是UUID  可能和XFCE mount有关系   后来用uuid已正常 重分区系统也是同一个板 同一个CPU 不能在别的板搞过来

此问题 后来确定为让 sata线位置 

fdiskl -l Partition 1 does not start on physical sector boundary.
用命令行gpt 分区后 老提示空间不够 后来 用gparted 重新分区好了 

install Awesome

这个的问题是安装后 gdm 选择了 依然进入gnome3 在家里用 vbox 试过也是尴尬了呢
解决办法是 ,可以不用安装kde
  apt install lightdm  lxrandr
#apt-get install kde-plasma-desktop
其实是gdm3  识别不了awesome 而ssdm可以识别,那其实也可以试一下 是不是只安装其它dm就可以了

Awesome

install xmonad

曾经放弃 现在 又回来了,没声音也是在mate打开一下就有了呢

xmonad安装及入门配置

安装完好像进入不了呢 原因和楼上一样 xmonad 安装及入门配置

install lxde

apt-get install lxde


在Debian上用FVWM做自己的桌面

备份Clonezilla

install mate

#在公司的电脑不用安装这个了
sudo apt-get update
#This will install the base packages required for a minimal MATE desktop
sudo apt-get install mate-desktop-environment-core

#This will install the complete MATE desktop
sudo apt-get install mate-desktop-environment

#This will install the complete MATE desktop including a few extras
sudo apt-get install mate-desktop-environment-extras

http://wiki.mate-desktop.org/download

xrandr

图形界面的用 lxrandr

#if hdmi on home

#只开启外外接显示器并关闭本本自带显示器 省电
xrandr --output  HDMI-1  --mode 1920x1080 --output LVDS-1 --off

xrandr --output HDMI-1 --same-as   LVDS-1  --mode 1366x768  --output HDMI-1 --mode 1920x1080

linux桌面(Dedian Ubuntu kali) 多显示器支持

xrandr — fvwm 双显示器

all4one

apt install  synapse tree  anjuta  geany spyder zim  remmina vlc  -y 
#sudo apt-get install fcitx fcitx-table-wbpy ttf-wqy-microhei ttf-wqy-zenhei
sudo apt-get install alarm-clock-applet 
 #eclipse  emacs  pycharm  chrome  自己独立安装 

解决没有声音:

  sudo apt install  pulseaudio
systemctl --user enable pulseaudio && systemctl --user start pulseaudio
  systemctl --user enable pulseaudio #打开声音控制就好了
打开打开声音控制 然后
语音控制--输入设备--输入插孔 记得好个小锁头要打开

还有 就是 输出设备为  模拟耳机 20181023

可能还有回放要 chrome

install applications

大不了在启动是 用 win+R 先启动kupfer

launcher

rofi_on_awesome

synapse

快捷键一般设置 为menu(win右边那个) 实在不行就设置 为 win +` or ctrl+1

kupfer

gnome-do

apt-get install gnome-do gnome-do-plugins.

Linux 下的护眼软件

视频播放

vlc

apt install vlc # 也有升级功能  继续播放功能升级为3.0.6 版本就可以了

smplaye

echo 'deb http://download.opensuse.org/repositories/home:/smplayerdev/Debian_9.0/ /' > /etc/apt/sources.list.d/home:smplayerdev.list
apt-get update
 sudo apt-get install smplaye# 好用 可提高音量到200% 看py 教程非常 爽 vlc都没这么好 也可手工下载包安装 

SMPlayer使用

smplayer安装教程

软件参考

办公软件

abiword and gnumeric

libreoffice

libreoffice installation

适用于 LibreOffice 的中日韩字体

wps

http://community.wps.cn/download/

问题
依赖关系问题使得 wps-office 的配置工作不能继续:
 wps-office 依赖于 libpng12-0;然而:
  未安装软件包 libpng12-0。
  
wget http://ftp.cn.debian.org/debian/pool/main/libp/libpng/libpng12-0_1.2.49-1+deb7u2_amd64.deb
sudo dpkg -i libpng12-0_1.2.49-1+deb7u2_amd64.deb
sudo dpkg -i wps-office_10.1.0.5672-a21_amd64.deb

libpng12-0未安装错误

wps字体

CAD

freecad

sudo add-apt-repository ppa:freecad-maintainers/freecad-stable
sudo apt update
 sudo apt install freecad

https://wiki.freecadweb.org/Install_on_Unix/zh-cn https://launchpad.net/~freecad-maintainers/+archive/ubuntu/freecad-stable

https://github.com/FreeCAD/FreeCAD/releases/tag/0.18.4

email

thunderbird

emacs26 in Ubuntu 18.04

 sudo add-apt-repository ppa:kelleyk/emacs
 sudo apt update

  sudo apt install emacs26

[email protected]:/usr/share/applications# cat emacs25.desktop 
[Desktop Entry]
Version=1.0
Name=GNU Emacs 25 (GUI)
GenericName=Text Editor
Comment=GNU Emacs is an extensible, customizable text editor - and more
MimeType=text/english;text/plain;text/x-makefile;text/x-c++hdr;text/x-c++src;text/x-chdr;text/x-csrc;text/x-java;text/x-moc;text/x-pascal;text/x-tcl;text/x-tex;application/x-shellscript;text/x-c;text/x-c++;
TryExec=/usr/bin/emacs25
Exec=/usr/bin/emacs25 %F
Icon=emacs25
Type=Application
Terminal=false
Categories=Utility;Development;TextEditor;
StartupWMClass=Emacs
Keywords=Text;Editor;
[email protected]:/usr/share/applications# cp  emacs25.desktop  emacs.desktop
[email protected]:/usr/share/applications# emacs  -nw  emacs.desktop 
[email protected]:/usr/share/applications# cat emacs.desktop
[Desktop Entry]
Version=1.0
Name=GNU Emacs 26 (GUI)
GenericName=Text Editor
Comment=GNU Emacs is an extensible, customizable text editor - and more
MimeType=text/english;text/plain;text/x-makefile;text/x-c++hdr;text/x-c++src;text/x-chdr;text/x-csrc;text/x-java;text/x-moc;text/x-pascal;text/x-tcl;text/x-tex;application/x-shellscript;text/x-c;text/x-c++;
TryExec=/usr/bin/emacs26
Exec=/usr/bin/emacs26 %F
Icon=emacs25
Type=Application
Terminal=false
Categories=Utility;Development;TextEditor;
StartupWMClass=Emacs
Keywords=Text;Editor;


http://ubuntuhandbook.org/index.php/2019/04/gnu-emacs-26-2-released-install-in-ubuntu-18-04/

emacs25

apt install emacs -y

How to Compile Emacs on Linux

Emacs入门

文件管理

apt install   pcmanfm-qt # thunar

终端软件

apt install terminator #tilix # ssh tools  pacmanager

terminator基础

下载工具

music

deadbeef

建议用deadbeef直接下载deb包

plugins

quodlibet

# deb http://lazka.github.io/ql-debian/testing/ quodlibet-unstable/
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 5A62D0CAB6264964
sudo apt-get update
sudo apt-get install quodlibet

Audacity

Audacity音频处理 Audacity 多轨跨平台的音频编辑软件

install rednotebook

#太老版本,不建议用
#apt-get install rednotebook  

sudo apt install python3-yaml

#2020
rednotebook$ sudo python3  setup.py  install 


#or 问题 新版本的图片看不到了
wget -c https://github.com/jendrikseipp/rednotebook/archive/v2.6.1.tar.gz
#wget -c --no-check-certificate https://github.com/jendrikseipp/rednotebook/archive/v2.6.1.tar.gz
tar xvf v2.6.1.tar.gz
sudo mv rednotebook-2.6.1 /opt/rednotebook
vi  /usr/share/applications/rednotebook.desktop 

[Desktop Entry]
Encoding=UTF-8
Name=rednotebook
GenericName=rednotebook
Comment[zh_CN]=日志本
Comment= journal
#Exec=/home/evan/software/rednotebook-2.2/run
#Icon=/home/evan/software/rednotebook-2.2/rednotebook.png
Exec=/opt/rednotebook/run
Icon=/opt/rednotebook/rednotebook.png
Terminal=false
X-MultipleArgs=false
StartupWMClass=Firefox
Type=Application
Categories=Utility;TextEditor;GTK;
MimeType=text/html;text/xml;application/xhtml+xml;application/xml;application/rss+xml;application/rdf+xml;image/gif;image/jpeg;image/png;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;x-scheme-handler/chrome;video/webm;application/x-xpinstall;


#sudo mv /usr/bin/rednotebook /usr/bin/rednotebook1.4
#sudo ln -s /home/evan/software/rednotebook-1.10.1/rednotebook/rednotebook  /usr/bin/rednotebook


家目录  /home/evan/.rednotebook
rsync  -avz  /home/evan/.rednotebook/  192.168.0.176:/home/evan/.rednotebook/

Rednotebook

install bluefish

Bluefish is a powerful editor targeted towards programmers and webdevelopers, with many options to write websites, scripts and programming code.

sudo apt install bluefish


http://pkg.kali.org/pkg/bluefish

官网

Installing Bluefish

install Sublime Text 3

wget -qO - https://download.sublimetext.com/sublimehq-pub.gpg | sudo apt-key add -
sudo apt-get install apt-transport-https
echo "deb https://download.sublimetext.com/ apt/stable/" | sudo tee /etc/apt/sources.list.d/sublime-text.list
sudo apt-get update &&  sudo apt-get install sublime-text
 

官方参考

IM

https://signal.org/

解压后复制到  /opt/Telegram/Telegram
/usr/bin$ sudo ln -s  /opt/Telegram/Telegram   telegram-desktop #要新的 用下载的吧
 apt install  telegram-desktop

2.1.5 与fictx冲突 换回2.1.4 https://telegram.org/ https://pkg.kali.org/pkg/telegram-desktop

wechat

https://gitee.com/lizhuohuan/docker-wechat

QQ

ps  QQ 有些 平铺下退出   ,换个样式就可以了


[email protected]:~# bash -x  linuxqq_2.0.0-b1-1024_x86_64.sh 
+ [[ root != \r\o\o\t ]]
+ lines=33
+ tarball_md5=f90cfea5999cf4eaafba0b8f0a2f80f8
+ tail -n+33 linuxqq_2.0.0-b1-1024_x86_64.sh
++ md5sum linuxqq.tar.gz
++ cut '-d ' -f1
+ md5=f90cfea5999cf4eaafba0b8f0a2f80f8
+ [[ f90cfea5999cf4eaafba0b8f0a2f80f8 != \f\9\0\c\f\e\a\5\9\9\9\c\f\4\e\a\a\f\b\a\0\b\8\f\0\a\2\f\8\0\f\8 ]]
+ export -f do_install
+ tar zxf linuxqq.tar.gz
+ find linuxqq/ -type f -exec bash -c 'do_install "{}"' ';'
installing /usr/share/applications/qq.desktop
installing /usr/share/tencent-qq/crashpad_handler
installing /usr/share/tencent-qq/qq
installing /usr/share/tencent-qq/res.db
installing /usr/share/tencent-qq/qq.png
installing /usr/share/tencent-qq/qq.bmp
+ rm -rf linuxqq linuxqq.tar.gz
+ exit 0

浏览器

chrome

方法一:在官网下载对应版本的deb后执行

 google-chrome-stable #平时升级
 

全局翻墙安装插件


Google Chrome有众多的出色的插件,说几个常用的 suspender:内存不够用,可以装个suspender插件,把其他暂时不看的tab中断掉 AdBlock:最受欢迎的Chrome扩展,拥有超过4000万用户!屏蔽整个互联网上的广告 The QR Code Extension:允许当前页面生成QR码,并使用网络摄像头扫描QR码。 Window Resizer:调节屏幕的分辨率,诸多时候用户开发 Vimium:vim的分身 Proxy SwitchyOmega:轻松快捷地管理和切换多个代理设置 Wechat:微信 马克飞象:使用印象笔记扩展程序一键保存精彩网页内容到印象笔记帐户 惠惠购物助手:【网易出品】在您网购浏览商品的同时,自动对比其他优质电商同款商品价格,并提供商品价格历史,帮您轻松抄底,聪明网购不吃亏 JSON-handle:顾名思义就是处理JSON数据的工具

使用 Apt 软件源安装谷歌 Chrome 通过shadowsocks翻墙

firefox

sudo apt install firefox-esr-l10n-zh-cn #如果用自带的esr版本
常用插件  Auto Tab Discard, Notifier for Gmail ,   Tab Suspender 

firefox安装和汉化

firefox新手上路

chromium

apt install chromium chromium-l10n

https://wiki.debian.org/Chromium

falkon

sudo apt-get install falkon

又一个轻量的web 浏览器 以前的 Qupzilla apt 会提示你的 2017年8月10日,QupZilla开发者David Rosca在博客宣布QupZilla成为KDE项目。[5]Qupzilla 2.2发布之后项目将更名为“Falkon”。[6]KDE Falkon 3.0于2018年2月27日发布。 qupzilla conitnues development as falkon browser


tor

gnome-web

apt install  epiphany-browser

midori

这个暂时安装上不好用 以前可以 直接 apt

download tools

axel 还是最爽的 下载rapian就知了

有道词典

http://cidian.youdao.com/index-linux.html

  1. 在官网下载对应版本的deb后执行
sudo dpkg -i *.deb && sudo apt-get install -fy

x11vnc

x11vnc是一种 位图显示的 视窗系统 。它是在 Unix 和 类Unix 操作系统 ,以及 OpenVMS 上建立图形用户界面的标准工具包和协议。x11vnc服务端可以实现Windows远程Linux桌面系统。

sudo apt-get install x11vnc

python

sudo apt-get install ipython3


kali linux Python开发环境初始化

python IDE

sudo apt-get install spyder3

https://docs.spyder-ide.org/installation.html#

ops tools

sudo apt install lrzsz #sz命令发送文件到本地: # sz filename

catfish

sudo apt-get install catfish #catfish简称文件搜索神器

django

pip install Django==1.8.18

#on ~/.bashrc
alias django-admin='/home/evan/.local/lib/python2.7/site-packages/django/bin/django-admin.py' 

electronic-wechat

electronic-wechat是一个基于nodeJS开发的Linux系统微信。

git clone https://github.com/geeeeeeeeek/electronic-wechat.git
cd electronic-wechat
npm install && npm start  #bash: npm: 未找到命令

bash: npm: 未找到命令
curl -sL https://deb.nodesource.com/setup_8.x | sudo -E bash -
sudo apt-get install -y nodejs

截图

flameshot

sudo apt install flameshot

https://flameshot.js.org/#/getting-start

Flameshot:一个简洁但功能丰富的截图工具

Shutter

gnome-screenshot
apt install shutter
sudo apt install deepin-screenshot -y

deepin scrot

sudo apt install deepin-screenshot -y


wget -c http://packages.linuxdeepin.com/deepin/pool/main/d/deepin-scrot/deepin-scrot_2.0-0deepin_all.deb
sudo dpkg -i deepin-scrot_2.0-0deepin_all.deb
sudo apt-get install -f
#使用
deepin-scrot

图标 
https://github.com/lovesnow/pystorm
在这 里选择另存为  default/start_cursor.png


screenshot

vi /usr/share/applications/scrot.desktop
[Desktop Entry]
Name=scrot
Name[zh_CN]=抓图
Comment=Save images of your desktop or individual windows
Comment[zh_CN]=保存您桌面还是单个窗口的图像
Exec=/usr/bin/deepin-scrot
Terminal=false
Type=Application
Icon=/home/evan/screenshot/start_cursor.png
StartupNotify=true
Categories=GTK;Utility;
Keywords=MATE;screenshot;snapshot;desktop;window;image;
OnlyShowIn=MATE;
X-MATE-Bugzilla-Bugzilla=MATE
X-MATE-Bugzilla-Product=mate-utils
X-MATE-Bugzilla-Component=screenshot
X-MATE-Bugzilla-OtherBinaries=mate-panel-screenshot

https://wiki.debian.org/ScreenShots

/usr/share/applications# find ./ -name "*scree*"

安装 Linux Deepin 截图工具

深度截图工具(DEEPIN-SCROT

XMind

XMind是一款实用的思维导图软件,简单易用、美观、功能强大,拥有高效的可视化思维模式,具备可扩展、跨平台。但是对于稳定性和性能还是欠佳,在ubuntu上使用占用很大的CPU资源。

  1. 在官网下载对应版本的deb后执行
sudo dpkg -i *.deb && sudo apt-get install -fy

远程桌面软件

Remmina

Remmina是一个用远程桌面软件,提供了RDP、VNC、XDMCP、SSH等远程连接协议的支持。 家里有时连不上是原来的网线接口不太好,重插一下就好了  
 sudo apt-get install remmina

usage

高级-- 画质 --  最好 

基本--色深--真色32位

rdesktop

有时,有个备份的软件很重要 上次Remmina老是自动全屏,每次连接win后老是要断开 烦死了,于是找了一下 发现这货 记录一下 我的常用使用命令

rdesktop  -g 1280x960 192.168.30.54

在Linux上使用rdesktop

arch rdesktop

freerdp

freerdp.com

 apt install freerdp-x11 freerdp2-x11

http://manpages.ubuntu.com/manpages/xenial/man1/xfreerdp.1.html

https://www.jianshu.com/p/f6fcf5b56fe3

数据库连接

Dbeaver安装

思维导图

freeplane

IDE

eclipse

https://www.eclipse.org/downloads/eclipse-packages/

Ubuntu 18.04下JDK与Eclipse安装配置



cat /usr/share/applications/eclipse.desktop
[Desktop Entry]
Name=eclipse
Name[zh_CN]=eclipse IDE
GenericName=Integrated Development Environment
GenericName[zh_CN]=集成开发环境
Comment=Develop software in an integrated development environment
Comment[zh_CN]=在集成开发环境中开发软件
Encoding=UTF-8
Exec=/home/evan/apps/eclipse/eclipse
Icon=/home/evan/apps/eclipse/icon.xpm
Terminal=false
X-MultipleArgs=false
StartupWMClass=Firefox
Type=Application
Categories=GNOME;GTK;Development;IDE;
StartupNotify=true

Meld

Meld是针对开发者的视觉差异和合并工具。MELD帮助您比较文件、目录和版本控制的项目。它提供了两个和三个比较的文件和目录,并支持许多流行的版本控制系统。既可以查看差异有可以同步!

sudo apt-get install meld

spyder

Python的开源IDE 可在MIT许可下免费使用 Spyder python的一些基本特性是多语言编辑器,交互式控制台,文档查看器,变量浏览器,在文件中查找,文件浏览器等 虽然Spyder是一个独立的IDE,支持包括Windows,Linux,MacOS,MacOS X等多个平台,但它也可以作为一个PyQt扩展库嵌入到PyQt应用程序

sudo apt-get install spyder 

https://pythonhosted.org/spyder/index.html

链接:https://github.com/spyder-ide/spyder

https://pythonhosted.org/spyder/installation.html

问题就是在awesome环境中fcitx 不能打中文

albert

wget -c http://repo.adminlounge.org/pool/dists/jessie/main/a/albert/albert_0.12_amd64.deb 
sudo dpkg -i albert_0.12_amd64.deb  && sudo apt-get install -fy

https://albertlauncher.github.io/docs/installing/ 官方安装命令好像不成功呢 所以 我直接拿出deb包了


install eric6

eric6 支持 py2 and py3 
 sudo apt install eric -y 

安裝插件 
插件--> 插件儲存庫 -->  然後都是下載 安装 下一步什么 的就行了 

问题就是导致fcitx 不能打中文


Debugging with the Eric IDE
I would sum up how to debug with the Eric IDE too:

F5 (start debugging; untick “Don’t stop at first line” or set a breakpoint)
F10 (stop)
F7 (next, step in subroutines)
F8 (next, step over subroutines)
F9 (return, step out of subroutine)
F6 (continue, go, run)
Shift+F6 (continue till cursor)
conditional breakpoints are supported (set a breakpoint, right click on it, edit)
I find Eric’s debugger is much faster than Winpdb.0


trouble shooting

下列软件包有未满足的依赖关系:
 libkf5coreaddons5 : 破坏: libkf5globalaccel-bin (< 5.37) 但是 5.28.0-1 正要被安装
 libkf5crash5 : 破坏: libkf5globalaccel-bin (< 5.37) 但是 5.28.0-1 正要被安装
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。


如果用新立得 就是提示 
无法应用变更! 请先修复损毁的软件包

结果这样就好了 
sudo apt-get install -f
sudo dpkg --configure -a

sudo apt-get dist-upgrade



#这个小心点
sudo apt-get autoremove

http://eric-ide.python-projects.org/

http://pydev.sourceforge.net/

IDE for python and django development on linux

Manually Installing the Django Plugin for Eric

Figlet

一句话:Figlet是一个将字符串在终端生成一个logo的终端工具。

sudo apt-get install figlet

figlet mylove

bleachbit

sudo apt install bleachbit
sudo  bleachbit #有中文界面

用于Ubuntu的6款最佳CCleaner替代品

chmsee

chmsee

打印机

惠普(HP_LaserJet_Professional_M1216nfh_MFP)HP打印机驱动安装

apt我使用的办法
1、打开深度终端,输入:sudo apt-get update && sudo apt-get install hplip hplip-gui hplip-plugin 
libcups2 libcups2-dev cups-bsd cups-client libcupsimage2 libcupsimage2-dev libdbus-1-dev

2、接着终端输入:hp-setup, 按照提示一路下一步 https://developers.hp.com/hp-linux-imaging-and-printing/install/manual/hp_setup


https://wiki.deepin.org/index.php?title=%E6%89%93%E5%8D%B0%E6%9C%BA

官方下载

https://developers.hp.com/hp-linux-imaging-and-printing/gethplip

https://developers.hp.com/hp-linux-imaging-and-printing/install


https://developers.hp.com/hp-linux-imaging-and-printing/install/install/index

故障处理

Searching... (bus=net, timeout=5, ttl=4, search=(None) desc=0, method=slp) error: No PPD found for model laserjet_professional_m1216nfh_mfp using old algorithm. error: No appropriate print PPD file found for model hp_laserjet_professional_m1216nfh_mfp

HP_LaserJet_Professional_M1216nfh_MFP

Would you like to specify the path to the correct PPD file to use (y=yes, n=no*, q=quit) ? y

解决办法 启动cups

sudo /etc/init.d/cups start

虚拟机软件

myos is  kali 2020.2


 sudo apt --fix-broken install
  416  sudo apt install linux-headers-5.4.0-kali4-amd64
  sudo apt install libsdl-ttf2.0-0
  
  
去掉vbox官方的源   
然后  sudo apt install virtualbox  就是最新的6.1的  原来自己的源里有哦  

用二进制包有错 和官方源有问题的 不用理了 



#国内mirrors
https://mirrors.tuna.tsinghua.edu.cn/virtualbox/


https://mirrors.tuna.tsinghua.edu.cn/virtualbox/6.1.4/virtualbox-6.1_6.1.4-136177~Debian~buster_amd64.deb


 sudo apt install virtualbox

https://download.virtualbox.org/virtualbox/6.0.10/virtualbox-6.0_6.0.10-132072~Ubuntu~bionic_amd64.deb


myos is  kali 2017.3
Debian 9 ("Stretch")  i386 |  AMD64
wget -c http://download.virtualbox.org/virtualbox/5.2.2/virtualbox-5.2_5.2.2-119230~Debian~stretch_amd64.deb

apt install  linux-headers-amd64 linux-headers-4.13.0-kali1-amd64
sudo /sbin/vboxconfig



if  ubuntu18.04
去清华大学 mirros 下载 6.1  有问题就  sudo apt --fix-broken install

http://pkg.kali.org/pkg/virtualbox

VirtualBox 镜像使用帮助

keepass2

sudo apt install keepass2

翻墙

Chrome通过shadowsocks翻墙

Ubuntu利用shadowsocks和polipo终端翻墙

 sslocal -s linuxsa.org   -p 443  -k "lai22" -l 7070 -t 600 -m aes-256-cfb #on new kali 加 /etc/rc.local

#!/bin/bash
source /etc/profile #一定要加  不然可能sslocal都说找不到 
ps -ef | grep sslocal | grep -v grep 
if [ $? -ne  0 ]
then 
/usr/bin/python /usr/local/bin/sslocal -s linuxsa.org   -p 443  -k "lai2240" -l 7070 -t 600 -m aes-256-cfb #on new kali
else
#echo "has run "
:
fi








#!/bin/bash
# */1  * * * * /home/evan/tunnel  &  #加定时任务不好 还不如用加配置的高级些呢 
#CPID=$$   #$$ 是脚本运行的当前进程ID号
#RUN="`ps -ef | grep "$0" | grep -v "grep" | grep -v "$CPID" | wc -l`"  #$0 是脚本本身的名字
RUN="`ps -ef | grep  -v "grep" | grep 7070 | wc -l`"
[ "$RUN" -gt 0 ] && exit
#[ "$RUN" -gt 1 ] && exit
#sleep 1

# freebsd  
#ssh  -i /home/evan/.ssh/evankey -p 22  -q  -D 7070 [email protected] 

#ssh -2  -N  -f    -p 22   -D 7070 [email protected]
#ssh  -i /home/evan/.ssh/evankey -p 22  -q  -D 7070 [email protected] &
#ssh -2 -N -f -L 7070:localhost:22  [email protected] 

#4 linux
# sudo killall sshd
ssh -i /home/evan/.ssh/id_rsa -p 22 -qtfnN -D 7070 [email protected]
sleep 3
#[ "$RUN" -gq 0 ] && exit
#[ "$RUN" -gt 1 ] && exit

lua

sudo apt install   lua5.1

[email protected]:~/test$ lua 
Lua 5.1.5  Copyright (C) 1994-2012 Lua.org, PUC-Rio

DM

GDM

gdm3

LightDM

为什么不能列出已有用户呢 我改了 居然不能login

SDDM

apt install sddm

redis-cli

sudo  apt install  redis-tools

vokoscreen录屏

sudo apt-get install vokoscreen

Kazam录屏

apt install kazam #昨天好像是安装不成功呀

http://pkg.kali.org/pkg/kazam

https://linsir.org/post/How_to_install_Kazam_on_kali_linux

好用轻巧的录屏软件——Kazam


Vokoscreen:优秀的屏幕录制软件


8 Best Screen Recorders for Desktop Screen Recording in Linux

https://www.tecmint.com/best-linux-screen-recorders-for-desktop-screen-recording/

https://itsfoss.com/best-linux-screen-recorders/

vpn

apt-get install network-manager-openvpn-gnome
apt-get install network-manager-pptp
apt-get install network-manager-pptp-gnome
apt-get install network-manager-strongswan
apt-get install network-manager-vpnc
apt-get install network-manager-vpnc-gnome
/etc/init.d/network-manager restart

ubuntu vpn

vnc

sudo apt install vnc4server
vncserver

Use xtigervncviewer -SecurityTypes VncAuth -passwd /root/.vnc/passwd :1 to connect to the VNC server.
0x03 安装VNC,远程桌面你的kali

还是先用ssh连接到kali,然后

##apt-get install tightvncserver

安装完之后,开启vnc连接

##tightvncserver

会提示你输入远程时要验证的密码,输入你的密码(系统会提示你需要一定复杂度

参考 http://www.52pi.net/archives/908


KALI中如何启用VNC

kali linux 2.0 实现vnc远程桌面连接

Kali Linux开启VNC远程桌面登录

IRC

hexchat 可惜输入框有点小 暂时不太会用

quassel

IRC 在Pidgin 中的设置

IM

微信 for Linux

https://github.com/geeeeeeeeek/electronic-wechat/blob/master/README_zh.md#%E5%A6%82%E4%BD%95%E4%BD%BF%E7%94%A8

编程

Svn基础

sudo apt install subversion kdesvn

思维导图

FreeMind Freeplane

为Linux用户推荐几种免费思维导图软件

打印机

运行 “开始” - ”控制中心 “ - “打印” - "服务器“ 设置共享打印机;然后另外一台 StartOS 机器,在连接打印机中选择”网络打印机“,选择”互联网打印协议(IPP)“,在 URI 输入条中输入共享打印机的地址,格式为 ipp://hostname:631/printers/<打印机的名称>,例如: ipp://192.168.0.1:631/printers/DeskJet-D2300,再根据提示操作即可

静态IP

sudo cat /etc/NetworkManager/system-connections/Wired\ connection\ 1 
[connection]
id=Wired connection 1
uuid=b2931303-64fc-45e7-88f1-31e160ead5cc
type=ethernet
permissions=
timestamp=1558878910

[ethernet]
mac-address-blacklist=

[ipv4]
address1=192.168.88.4/24,192.168.88.1
dns=223.6.6.6;
dns-search=
method=manual

[ipv6]
addr-gen-mode=eui64
dns-search=
ip6-privacy=2
method=ignore

清理工作

Debian/Ubuntu清理硬盘空间的8个技巧

apt clean #释放空间 /var/cache/apt/archives/ 里面会有大量下载的软件包


cd / 
du  -sh  * --exclude=home #查看除了home目录,哪个目录是最大的

du -s * | sort -nr|head # 排序

思路 在最大的里面删除 或者直接看到哪些没用的,直接删除 例如share/doc


[email protected]:/usr# du -s * | sort -nr|head
8290868	lib
5811564	share
1070492	bin
173016	local
158300	src
149140	include
58604	sbin
9188	lib32
76	libexec
[email protected]:/usr# du -sh lib
8.0G	lib
[email protected]:/usr# du -sh   share/
5.6G	share/




 sudo apt purge libreoffice?
使用'sudo apt autoremove'来卸载它(它们)。

瘦身

apt remove rhythmbox  atril  pluma  uxterm xterm

apt autoremove  gir1.2-pluma-1.0 gir1.2-rb-3.0 libgpod-common libgpod4 libpeas-1.0-python2loader \
 librhythmbox-core10 libsgutils2-2 pluma-common rhythmbox-data


#/usr/share/doc: 系统说明文件存放目录
[email protected]:~$ sudo mv /usr/share/doc/* bakdock/

remove different Desktop

sudo apt-get remove kde* plasma* plasma-desktop* plasma-desktop
sudo apt-get remove kde-plasma-desktop kde-plasma-netbook kde-standard

How to install/remove different Desktop

apt 源目录

http://mirrors.aliyun.com/kali/pool/main/c/catfish/catfish_1.4.4-1_all.deb

xfce

Xfce面板操作手册 Xfce4.2操作手册

Xfce (arch)

Xfce4.2用户指南

Xfce/指南(gentoo)

xfce ​百科

move files

0.on debianpc 

*/5 * * * *  rsync -avz  xk/  data/xkbak/
*/40 * * * *  rsync -avz  ssh/  data/xkbak/ssh/


1. 先把latop的东西 rsync 到 mydata  #
cd /mydata
rsync -avz --progress  192.168.11.28:/home/evan/*  .

2.再把pc 有关的cp 到mydata
#on pc run  command
rsync  -avz --progress   ~/dkm/*  192.168.11.28:/home/evan/dkm/

#不然是变成 下面的一个子目录了
#cp dir1  dir2
#cp dir1/ dir2/ #变成子目录
rsync -avz --progress  .config/awesome/*   192.168.11.28:/home/evan/awesome
rsync  -avz --progress   book/*  192.168.11.28:/home/evan/book/


#这个要先清理一下先 
#rsync 到 此目录 
rsync -avz --progress /home/evan/rom/* 192.168.11.28:/home/evan/rom/
#同上
rsync -avz --progress /home/evan/rom/ 192.168.11.28:/home/evan/rom 
不会成为子目录哦
rsync -avz --progress /home/evan/rom/ 192.168.11.28:/home/evan/rom/

troubleshooting

watchdog

现在看起来是那个外带的无线网上问题 还是感觉 kali 相比debian有点卡

Message from [email protected] at Oct 13 12:47:30 ...
 kernel:[ 2897.771142] watchdog: BUG: soft lockup - CPU#1 stuck for 22s! [netstat:3680]

Message from [email protected] at Oct 13 12:47:58 ...
 kernel:[ 2925.770120] watchdog: BUG: soft lockup - CPU#1 stuck for 22s! [netstat:3680]

Firmware https://wiki.debian.org/Firmware

kernel BUG: soft lockup - CPU stuck for 23s!

小心 更新系统

2018年 09月 23日 星期日 18:37:21 CST 这个主板 CPU 太新 一开始安装不上,搞了N久,后来 拿回家在家里的老主板上安装成功,然后拿到新主机机器上 一开始好好的 ,可惜我突然又想更新 于是又挂了呀

乱码 kali light

 apt install  ttf-wqy-microhei ttf-wqy-zenhei xfonts-wqy  # reboot ok

安装kali-linux-full,包含各种工具:
$ sudo apt-get install kali-linux-full

安装GNOME 3桌面环境:
$ sudo apt-get install kali-desktop-gnome


安装kali-light版本后使用中文出现乱码签名无效

realtek

http://mirrors.ustc.edu.cn/debian/pool/non-free/f/firmware-nonfree/firmware-realtek_20161130-3_all.deb

apt lock

[email protected]:~# apt-get install openssh-client 
E: 无法获得锁 /var/lib/dpkg/lock - open (11: 资源暂时不可用)
E: 无法锁定管理目录(/var/lib/dpkg/),是否有其他进程正占用它?
[email protected]:~# apt \\^C
[email protected]:~# apt install openssh-client 
E: 无法获得锁 /var/lib/dpkg/lock - open (11: 资源暂时不可用)
E: 无法锁定管理目录(/var/lib/dpkg/),是否有其他进程正占用它?
[email protected]:~# apt update 
命中:1 http://mirrors.neusoft.edu.cn/kali kali-rolling InRelease
正在读取软件包列表... 完成   
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       

[email protected]:~# ps -ef | grep apt 
_apt      1400   667  0 15:36 ?        00:00:00 /usr/lib/apt/methods/http
_apt      1401   667 11 15:36 ?        00:00:13 /usr/lib/apt/methods/http

[email protected]:~# ps -ef | grep dpkg 
root      1525  1380  0 15:38 pts/1    00:00:00 grep dpkg
[email protected]:~# kill -9  1400  1401 

err

dpkg-deb: 错误: <解压缩> subprocess returned error exit status 2 dpkg: 处理归档 /var/cache/apt/archives/libwebkit2gtk-4.0-37_2.22.0-2_amd64.deb (--unpack)时出错:

无法为 './usr/lib/x86_64-linux-gnu/libwebkit2gtk-4.0.so.37.33.1' 拷贝解压的文件至 '/usr/lib/x86_64-linux-gnu/libwebkit2gtk-4.0.so.37.33.1.dpkg-new': 未预期的文件结束或流结束

正准备解包 .../libjavascriptcoregtk-4.0-18_2.22.0-2_amd64.deb ... 正在将 libjavascriptcoregtk-4.0-18:amd64 (2.22.0-2) 解包到 (2.20.3-1) 上 ... dpkg-deb (子进程):解压缩归档成员:lzma 错误:压缩数据已损坏 dpkg-deb: 错误: <解压缩> subprocess returned error exit status 2 dpkg: 处理归档 /var/cache/apt/archives/libjavascriptcoregtk-4.0-18_2.22.0-2_amd64.deb (--unpack)时出错:

无法为 './usr/lib/x86_64-linux-gnu/libjavascriptcoregtk-4.0.so.18.11.1' 拷贝解压的文件至 '/usr/lib/x86_64-linux-gnu/libjavascriptcoregtk-4.0.so.18.11.1.dpkg-new': 未预期的文件结束或流结束

在处理时有错误发生:

/var/cache/apt/archives/libwebkit2gtk-4.0-37_2.22.0-2_amd64.deb
/var/cache/apt/archives/libjavascriptcoregtk-4.0-18_2.22.0-2_amd64.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)

华硕开机自动进入bios

#在新PC 安装了 kali,记得要删除整个硬盘,我使用了默认的分区,不然grub安装不成功, 加个数据硬盘后居然老是直接到BIOS
1.首先恢复一下bios默认值,避免其他参数变动影响

2..Security-->Secure Boot Management按回车进入设置菜单;将Secure Boot 改为Disabled

3.选择Boot进入启动设置,将Fast Boot设为disabled ,将Launch CSM设为Enabled; 

4.F10保存设置。重启进系统不再进bios

#这个办法 ?
首先进入bios

Security->Secure Boot Control->Disabled 
F10保存,继续进入bios

Boot->Launch CSM->Enabled
F10保存,成功进入系统

最后发现,如果在磁盘分区时候没选择全放在一起(即第一项推荐新手)而是选择了下面的2项就会导致安装操作系统失败

解决方案:我原本空闲出20G给kali,现在改为45G,安装时就不会失败了,详情见kali 安装步骤 安装失败 kali install fail 已解决,究其原因"/ 根目录" 要分10G以上(否则安装失败,x32和x64位的系统在两台电脑上面共尝试安装了10次左右没有成功,后来成功后总结出已知原因两点1,须选图形化安装2,手工分区,而且根目录足够大,此版本解压出来/根目录就7GB以上了

http://linuxbsdos.com/2016/11/05/dual-boot-kali-linux-rolling-2016-2-windows-10-on-a-pc-with-uefi-firmware/

pc err

mate err

您希望继续执行吗? [Y/n] y
dpkg-deb (子进程):解压缩归档成员:lzma 错误:压缩数据已损坏
dpkg-deb: 错误: <解压缩> subprocess returned error exit status 2
dpkg-deb (子进程):无法从 /var/cache/apt/archives/libgtk-3-0_3.24.1-2_amd64.deb 中拷贝归档成员到解码管道中:写入失败 (断开的管道)
读取变更记录(changelogs)... 完成
(正在读取数据库 ... 系统当前共安装有 436105 个文件和目录。)
正准备解包 .../libgtk-3-0_3.24.1-2_amd64.deb  ...
正在将 libgtk-3-0:amd64 (3.24.1-2) 解包到 (3.22.30-2) 上 ...
dpkg-deb (子进程):解压缩归档成员:lzma 错误:压缩数据已损坏
dpkg-deb: 错误: <解压缩> subprocess returned error exit status 2
dpkg: 处理归档 /var/cache/apt/archives/libgtk-3-0_3.24.1-2_amd64.deb (--unpack)时出错:
 无法为 './usr/lib/x86_64-linux-gnu/libgtk-3.so.0.2400.1' 拷贝解压的文件至 '/usr/lib/x86_64-linux-gnu/libgtk-3.so.0.2400.1.dpkg-new': 未预期的文件结束或流结束
正准备解包 .../mate-icon-theme_1.20.1-1_all.deb  ...
正在解包 mate-icon-theme (1.20.1-1) ...
dpkg-deb (子进程):解压缩归档成员:lzma 错误:压缩数据已损坏
dpkg-deb: 错误: <解压缩> subprocess returned error exit status 2
dpkg: 处理归档 /var/cache/apt/archives/mate-icon-theme_1.20.1-1_all.deb (--unpack)时出错:
 无法为 './usr/share/icons/mate/256x256/devices/video-display.png' 拷贝解压的文件至 '/usr/share/icons/mate/256x256/devices/video-display.png.dpkg-new': 未预期的文件结束或流结束
在处理时有错误发生:
 /var/cache/apt/archives/libgtk-3-0_3.24.1-2_amd64.deb
 /var/cache/apt/archives/mate-icon-theme_1.20.1-1_all.deb
办法 1 如何解决这个问题 看能不能这个

使用apt安装软件时,提示dpkg-deb: /lib/x86_64-linux-gnu/liblzma.so.5

dpkg-deb (子进程):解压缩归档成员:lzma 错误:压缩数据已损坏

办法2 重装 安装有gnome 就可以 全局ss 并安装chrome plus

ops

中文man手册

备用

完美工作站 Archlinux

参考资料

Linux系统装机必备应用top10

Linux上有哪些高效的工具软件?

高效 manjaro i3

安装完 Debian 10 后必做的10件事

ubuntu wiki apps 程序员的Linux常用软件清单

kali初始化myblog

Debian 10(Buster)安装后要做的前 8 件事

debian初始化 -testing

Kali Linux 配置和优化(安全牛学习笔记)

kali日常 无法应用变更! 请先修复损毁的软件包


kali初始化

Ubuntu 中软件的安装、卸载以及查看的方法总结

Install the Eric Python IDE


10个最佳 Python 集成开发环境(IDE)

Remmina的一次暴走

开启你的kali linux DIY之旅


Linux下给力截图工具归纳

Ubuntu安装腾讯TIM

Debian Xfce 安装后的常用配置教程

Remmina Ubuntu 和 Windows 之间进行远程访问和文件互传


vbox host kali 2020.1版本安装及中文汉化