Ubuntu 18.04 LTS/19.10 升级到 Ubuntu 20.04

来自linux中国网wiki
跳到导航 跳到搜索
其中 -d 参数表示需要查找开发版本:

update-manager -d -c 

cat /etc/os-release| grep -i version


https://linuxhint.com/upgrade_ubuntu_1804_2004/

https://zhuanlan.zhihu.com/p/127085398

sudo apt update &&  apt  upgrade 

sudo apt full-upgrade

sudo apt install ubuntu-desktop


准备升级20.04进入不了图形

应该是我一开始 加了 kali的源导致的

我的命令
进不入图形 其实是 dm坏了 
apt-get install lightdm
dpkg-reconfigure   lightdm

别人的命令
GDM出现了兼容性问题,换个其他的界面登录器(LightDM)就可以解决问题了
root用户下执行如下命令:

apt-get update
apt-get remove gdm3 如果没有gdm3,看看是否有gdm
apt-get autoremove 删除其他与gdm相关的依赖
apt-get install lightdm
reboot



 dpkg-reconfigure gdm3 
/usr/sbin/dpkg-reconfigure: gdm3 已被损坏或未完成安装


[email protected]:~# apt install  vlc 
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 vlc : 依赖: vlc-plugin-base (= 3.0.9.2-1) 但是 3.0.8-0ubuntu18.04.1 正要被安装
       推荐: vlc-plugin-samba (= 3.0.9.2-1) 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。


tail /var/log/dmesg
[    8.947629] kernel: iwlwifi 0000:02:00.0: Unhandled alg: 0x707
[    9.044541] kernel: iwlwifi 0000:02:00.0: Unhandled alg: 0x707
[    9.046797] kernel: iwlwifi 0000:02:00.0: Unhandled alg: 0x707
[    9.046823] kernel: iwlwifi 0000:02:00.0: Unhandled alg: 0x707
[    9.049244] kernel: iwlwifi 0000:02:00.0: Unhandled alg: 0x707
[    9.049270] kernel: iwlwifi 0000:02:00.0: Unhandled alg: 0x707
[    9.110074] kernel: iwlwifi 0000:02:00.0: Unhandled alg: 0x707
[    9.111316] kernel: iwlwifi 0000:02:00.0: Unhandled alg: 0x707
[    9.112531] kernel: iwlwifi 0000:02:00.0: Unhandled alg: 0x707
[    9.152835] kernel: iwlwifi 0000:02:00.0: Unhandled alg: 0x707

err

emoving obsolete dictionary files:
dpkg: 处理触发器时发现回路:
 包含或可能包含对此有责任的触发器的软件包链:
  fcitx-skin-sogou -> fcitx-skin-sogou -> fcitx-skin-sogou -> fcitx-skin-sogou -> fcitx-skin-sogou -> fcitx-skin-sogou -> fcitx-skin-sogou -> fcitx-skin-sogou
 无法解决的软件包未决触发器:
  menu: /usr/share/menu
  libvlc-bin:amd64: /usr/lib/x86_64-linux-gnu/vlc/plugins
  dbus: /etc/dbus-1/system.d
  libgdk-pixbuf2.0-0:amd64: /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders
  ca-certificates: update-ca-certificates
  fcitx-skin-sogou: /usr/share/fcitx/configdesc/fcitx-classic-ui.desc: /usr/share/icons/hicolor/scalable/apps/fcitx.svg
  initramfs-tools: update-initramfs
  linux-image-5.4.0-41-generic: linux-update-5.4.0-41-generic
dpkg: 处理软件包 menu (--configure)时出错:
 触发器循环,放弃
dpkg:../../src/packages.c:236:process_queue: 内部错误: exceeded dependtry 7 (sincenothing=0; queue.length=4)
E: Sub-process /usr/bin/dpkg exited unexpectedly
[email protected]:/etc/apt# cat /etc/os-release| grep -i version
VERSION="20.04 LTS (Focal Fossa)"
VERSION_ID="20.04"
VERSION_CODENAME=focal